検索
カレンダー
2020年2月
« 4月    
 1
2345678
9101112131415
16171819202122
23242526272829
ブログメニュー
Amazon検索
キーワード:

PHP5上でPHP4用のスクリプトを動かすためには

2006年10月18日

PHPの最新メジャーバージョンが5になってから結構経ちますが、まだPHP4が多く使われているように思います。
PHP5とPHP4では完全な互換がないことはよく知られていますが、PHP5をPHP4互換モードとして動かすことができるのはご存知でしょうか。
この設定はphp.iniだけでなく.htaccessで指定できるので、環境を混在させるときに便利です。
.htaccessで設定するときは以下のように記述します。

php_flag zend.ze1_compatibility_mode On

これを設定すると、『Zend Engine 1 (PHP 4) との互換モードを有効にします。 この設定は、オブジェクトのコピー、キャスト (プロパティを 保持しないオブジェクトが FALSE あるいは 0 のいずれになるか)、 そして 比較 に影響を与えます。このモードの場合、オブジェクトを渡す際の デフォルトの方法は、参照渡しではなく値渡しとなります。』だそうです。

参考:
コア php.ini ディレクティブに関する説明

コメントはまだありません »

コメントはまだありません。

TrackBack URL : http://www.meibinlab.jp/nishijima/archives/51/trackback

コメントする